Author Topic: Dedicated Server running off Digital Ocean - Inaccessible  (Read 611 times)

awfulcitizen

  • Newbie
  • *
  • Posts: 3
    • View Profile
Dedicated Server running off Digital Ocean - Inaccessible
« on: July 04, 2016, 11:39:03 am »
Hi,

I am running a server off a digital ocean droplet off Ubuntu 14.04 64bit.  I have a script that is launching the game as:

Code: [Select]
#!/bin/bash
/usr/bin/mono /home/server/voidexpanse/VoidExpanse.ServerMono.exe --dedicated load 0

the server launches and I get an error:

Code: [Select]
4.7.16 14:30:11.2420 [ERR] SocketServerUDP: Automatic UPnP port-forwarding failed. Port-forwarding status is unknown. Please manually forward the port on the router if the players cannot connect to the server.

A couple of seconds later it exits, this is the whole block:

Code: [Select]
4.7.16 14:30:00.6831 [IMP] Initializing ScriptManager
4.7.16 14:30:01.8208 [IMP] Stopwatch ScriptManager [parallel] Init AI scripts: 1144ms
4.7.16 14:30:02.5421 [IMP] Stopwatch ScriptManager [parallel] init Internal scripts: 720ms
4.7.16 14:30:02.5722 [IMP] data/scripts/global/CalculateShip.js: -- IMCache lib initialized
4.7.16 14:30:03.4771 [IMP] Stopwatch ScriptManager [parallel] load scripts global: 934ms
4.7.16 14:30:08.4959 [IMP] Stopwatch ScriptManager [parallel] load scripts topics: 5018ms
4.7.16 14:30:08.5259 [IMP] Stopwatch ScriptManager init (total): 7886ms
4.7.16 14:30:08.8237 [IMP] Stopwatch Devices & special objects scripts init (total): 222ms
4.7.16 14:30:08.8343 [IMP] Scripts and data initialized
4.7.16 14:30:08.8494 [IMP] Loading save game from slot slot_0 (from "/home/server/voidexpanse/Saves_Multiplayer/slot_0")
4.7.16 14:30:08.8498 [IMP] Stopwatch Server re-init scripts (total): 0ms
4.7.16 14:30:10.9685 [IMP] Scope distance set to 33.00
4.7.16 14:30:11.1500 [IMP] World successfully loaded from slot_0 (path "/home/server/voidexpanse/Saves_Multiplayer/slot_0")
4.7.16 14:30:11.1508 [IMP] Stopwatch Server re-init scripts (total): 0ms
4.7.16 14:30:11.1514 [IMP] World initialized with 0 players, 75 star systems, 7803 asteroids, 1140 ships, 31 bases, 191 jumpgates, 8277 spaceObjects, 213 specialObjects, 277 containers, 75 stars, 181 planets.
Difficulty: Normal
4.7.16 14:30:11.1875 [IMP] MasterServerClient: Received Command SetupEncryption (ID=43030)
4.7.16 14:30:11.1881 [IMP] MasterServerClient: Sending Command SetupEncryptionResult (ID=1)
4.7.16 14:30:11.2420 [ERR] SocketServerUDP: Automatic UPnP port-forwarding failed. Port-forwarding status is unknown. Please manually forward the port on the router if the players cannot connect to the server.
4.7.16 14:30:11.2944 [IMP] MasterServerClient: Received Command Ready (ID=43031)
4.7.16 14:30:11.2950 [IMP] MasterServerClient: MasterServer client ready to work
4.7.16 14:30:11.3058 [IMP] Registering as a Public Server on the Master Server
4.7.16 14:30:11.3062 [IMP] MasterServerClient: Sending Command RegisterPublicServer (ID=2)

Please advise as I have run out of ideas to get it runing.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 988
    • View Profile
Re: Dedicated Server running off Digital Ocean - Inaccessible
« Reply #1 on: July 04, 2016, 09:33:20 pm »
Hello!

This error is just a warning. The port forwarding is working only for home routers with UPnP technology.
I don't have any experience with Digital Ocean's droplets, but it seems you need to whitelist the game server port in the firewall. I suppose you've done basic setup for Ubuntu 14.04 droplet and have ufw firewall installed and active. If so, you can whitelist the game by executing this command:

Quote
sudo ufw allow 5000/udp
(please verify that the game server port is 5000 in the server log file - if not, replace it with your actual server port)

Then you can check the firewall status:
Quote
sudo ufw status verbose

If you don't have the firewall installed (all these commands returns some error saying "ufw" is unknown command) than that's not the case... You can try to install a web server and see if it's accessible. There is a good article about initial server setup and installing a web server (nginx) - https://www.digitalocean.com/community/tutorials/initial-server-setup-with-ubuntu-14-04

Regards!
« Last Edit: July 05, 2016, 04:27:31 am by Lurler »