Author Topic: Xenial, server stops at Initializing ScriptManager but see connections  (Read 1030 times)

Cybermind

  • Newbie
  • *
  • Posts: 25
    • View Profile
Hello :-) I have installed Xenial, Mono and VoidExpanse, but when launching the server app it stops at Initializing ScriptManager. It still sees connections when I launch VoidExpanse client app, but client never recieves server info.

EDIT: Right after typing stop + enter, it continued, wrote stopping server, and is new generating a new galaxy.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 988
    • View Profile
Re: Xenial, server stops at Initializing ScriptManager but see connections
« Reply #1 on: August 19, 2016, 11:27:42 pm »
Hello!

This is very strange... can you reproduce it? If yes, please upload the server log on pastebin.com; if no - well, there are various issues with Mono and I hope with one of the future patches we will be able to switch on CoreCLR (official Microsoft .NET Framework implementation for all desktop operating systems, just released v1.0).

Regards!

Cybermind

  • Newbie
  • *
  • Posts: 25
    • View Profile
Re: Xenial, server stops at Initializing ScriptManager but see connections
« Reply #2 on: August 20, 2016, 04:39:10 am »
Hi again :-)

It happens every time, it stops there until I press enter (maybe other keys will make it continue as well). I have now installed Ubuntu Mate 16.04, the server app does the same here.

Here is the pastebin log: http://pastebin.com/WMSRztnj

The performance is very slow on the Raspberry PI 2 with only one client on both Xenial and Mate (I have failed to disable the GUI on Mate 16.04), but Raspbian with no GUI is very playable with two clients when they are at the same map. I have ordered an Orange Pi with 1.6GHz instead of the Raspberry Pi 2 with only 900MHz, I am excited to see if this makes the server run better with clients at different maps. I am using these small all-in-ones as electricity is very expensive here in Denmark. The poor performance on Xenial and Mate might be linked to the error with the script manager, but this is only guess work :-)

I can see there is an Expansions button in the main menu now, are there any cool expansions coming up?

EDIT: I looked at the log, it seems that the server app is waiting for a command at script manager step.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 988
    • View Profile
Re: Xenial, server stops at Initializing ScriptManager but see connections
« Reply #3 on: August 20, 2016, 05:06:03 am »
Thanks for the detailed report! The scripting initialization step is usually the longest one, but should not take much more time than a loading of the savegame - which is in your case happens much faster. I think it maybe related to the disk reading pattern - as the scripting initialization step creates 4 threads to read-parse-compile all the scripts in the game - and if the disk system is not very fast with parallel simultaneous reading, it may cause the stall. Could you run "iotop" in parallel with the game and check if IO is 100% busy during the scripting initialization step?

We've tested the server on desktop OS's - Windows, Mac and Linux (Ubuntu 14 only, but on different configurations, including VMWare with very limited performance; also x86 and x86_64) - and cannot reproduce the issue... Unfortunately, we don't have here any computers with processors on RISC architecture (such as ARM processor in your Raspberry Pi 2). I think this might be related to the issue - not only because of performance, but also because of different Mono implementation for RISC processors...

I understand your energy-efficiency concerns. If you want something ultimate but with reasonable price and similar to Raspberry Pi 2 power consumption, I think you might like an x86-based micro-computer - like UDOO X86. It uses just a few percents more energy, but seems to be several times faster and can run any x86 OS. Personally, I'm looking for something like that for my 24/7 home server.

Regarding the Expansions button - there is an official response http://steamcommunity.com/app/324260/discussions/0/353916584666312753/

Regards!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 988
    • View Profile
Re: Xenial, server stops at Initializing ScriptManager but see connections
« Reply #4 on: August 20, 2016, 05:12:49 am »
EDIT: I looked at the log, it seems that the server app is waiting for a command at script manager step.
It's always listening to the commands, so if you press the Enter key it will print "Please enter command. Enter "help" for commands list.". I'm sure this is not related to the issue.