Author Topic: Error Message in Console! And a question about fuel consumption in-game!?  (Read 458 times)

ninekorn

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
There is a message in the console that is beeing displayed ever since I've created my test server today. It's never happened as much as it was doing so today. The message says
"[ERR] Ship not found: 0"
I think in the past, AI_enabled fixed one debug message like that but it was for Asteroids, if I remember correctly.
How does the fuel work in VoidExpanse?
Somehow, it feels like both the energy consumption and fuel consumption are linked together? I'm not sure if I'm wrong there.

Lurler

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1121
    • View Profile
Re: Error Message in Console! And a question about fuel consumption in-game!?
« Reply #1 on: February 07, 2018, 08:57:06 pm »
Can't answer about the bug, we will have to wait for the reply from ai_enabled.

But as for energy and fueld - the answer is yes. Fuel is consumed as the generator recharges your capacitor. If you don't do anything it will only drain a tiny bit of energy (and consequently fuel), but if you fly around and shoot non stop then it will eat a lot of energy and generator will use fuel to replenish it.

ninekorn

  • Jr. Member
  • **
  • Posts: 90
    • View Profile
Re: Error Message in Console! And a question about fuel consumption in-game!?
« Reply #2 on: February 07, 2018, 09:50:31 pm »
Ok about the energy and fuel. I'm gonna have to start looking in the CalculateShip.js to fiddle around with the "Too High" fuel consumption of the ship. I've already been able to stabilize the fuel consumption. So right now it stays at 100% almost all the time. I'll fiddle some more inside the script to get to understand where the functions are.

Here's a better view of the message. It has started 3 servers ago and now it won't stop.

« Last Edit: February 07, 2018, 10:21:41 pm by Lurler »

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1097
    • View Profile
Re: Error Message in Console! And a question about fuel consumption in-game!?
« Reply #3 on: February 09, 2018, 01:02:00 pm »
I think the error is quite different from what we had with the asteroids.
This error message appears if you're asking Scripting API to perform some action on a ship and the provided ship ID is 0. You can try to isolate some parts of your scripts to find the line which leads to this error message.
If you're unable to locate it, I will be able to look into the source of this issue when our vacation is over (we're going to a Lunar New Year holidays for the next ~1.5 weeks).

Regards!