Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Messages - PanBanan

Pages: [1]
1
Help section / Re: Server and Mod problem
« on: December 08, 2018, 04:05:47 am »
YEAY! Thank you Man! I knew I was doing something wrong :P
Many thanks to you for your help! You save my day! :)

CHEERS!

2
Mods / Re: Big Bad Wolves Mod
« on: December 07, 2018, 02:22:35 pm »
Hi, I tried to run this mod as well as other in mod section. It seems like there is some problem with running mods on newest version of the game.
Keep getting infinity loop.

Code: [Select]
PS F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Binaries\Server> dotnet .\CryoFall_Server.dll load
7.12.18 21:16:41.627 [IMP] CryoFall game server runtime v0.17.7.8
AtomicTorch Studio (c) 2015-2018
All rights reserved.
7.12.18 21:16:41.630 [IMP] Environment info:
OS: Microsoft Windows NT 6.2.9200.0 (Windows)
.NET version: .NET Core 4.6.27019.06 (is .NET Core: yes)
CPU count: 4
Is 64-bit process: yes
7.12.18 21:16:41.631 [IMP] Operations timed using the system's high-resolution performance counter.
  Timer is accurate within 309 nanoseconds
  Timer frequency in ticks per second = 3234375
7.12.18 21:16:41.643 [IMP] The settings file loaded successfully from F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Data\SettingsServer.xml
7.12.18 21:16:41.644 [IMP] Current log severity: Important
7.12.18 21:16:41.663 [IMP] Mods catalog info (known mods locations):
Core folder: "F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Core"
Mods folder (primary): "F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Mods"
Mods folder (secondary): "F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Data\Mods"
7.12.18 21:16:41.726 [IMP] Mods catalog initialzed. Available files:
core_1.0.0, DaitallicaBigBadWolves_1.0.0
7.12.18 21:16:41.732 [IMP] Mods config location: "F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Data\ModsConfig.xml"
Active core/mods list:
  * core - ClientServer v1.0.0 (from file "F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Core\Core.cpk")
  * DaitallicaBigBadWolves - ClientServer v1.0.0 (from file "F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Data\Mods\BigBadWolves.mpk")
7.12.18 21:16:41.817 [IMP] Virtual file system initialized successfully:
Core mod: Core
Mods list:
   * BigBadWolves
Total files count: 5238
7.12.18 21:16:41.829 [IMP] Initializing ScriptManager
7.12.18 21:16:41.830 [IMP] [Stopwatch] Init game file system: 96ms
7.12.18 21:16:41.859 [IMP] Network command binding completed successfully for command name enum types:
CommandNameCore, CommandNameMaster
Total bound commands count: 36.
7.12.18 21:16:41.878 [IMP] Modules initialized: Master, Auth, Player, World, Items, Core
7.12.18 21:16:41.883 [IMP] Server icon found at the server folder - "ServerIcon.png" (size: 64928 bytes)
7.12.18 21:16:41.883 [IMP] Scheduling request to load world (it will happen after reloading Core/Mods assembly)
7.12.18 21:16:41.883 [IMP] Destroying world and resetting objects repository in order to load savegame
7.12.18 21:16:41.885 [IMP] FPS set to 40; network physics updates per second: 20
7.12.18 21:16:41.886 [IMP] Server skip frames: 13
7.12.18 21:16:41.890 [IMP] Compiling/loading scripts started...
7.12.18 21:16:41.895 [IMP] Cache root path: C:\Users\Matek\AppData\Local\Temp\AtomicTorchStudio\CryoFall_v0.17.7
7.12.18 21:16:41.898 [IMP] Launching compiler process: dotnet F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Binaries\Shared\Compiler\CryoFall_Compiler.dll --fromGame load
7.12.18 21:16:41.904 [IMP] Network command binding completed successfully for command name enum types:
CommandNameCompiler
Total bound commands count: 2.
7.12.18 21:16:41.907 [IMP] [COMPILER CLIENT] IPCClient: Named pipe client connecting to COMPILER_at_F--Gry-CryoFall-Server-CryoFall_Server_v0.17.7.8_NetCore-Binaries-Shared-Compiler-CryoFall_Compiler.dll.IPC1234
7.12.18 21:16:42.068 [IMP] [COMPILER CLIENT] IPCClient: Named pipe client connected to COMPILER_at_F--Gry-CryoFall-Server-CryoFall_Server_v0.17.7.8_NetCore-Binaries-Shared-Compiler-CryoFall_Compiler.dll.IPC1234
7.12.18 21:16:42.071 [IMP] [COMPILER CLIENT] Connection to the Compiler Server localhost(IPC):1234 established successfully
7.12.18 21:16:42.072 [IMP] [COMPILER CLIENT] Sending build request: C:\Users\Matek\AppData\Local\Temp\AtomicTorchStudio\CryoFall_v0.17.7\Assemblies\Scripts_release_netcore_x64_crc16533242160812606244 isWarmUp=False forceOverwrite=False
7.12.18 21:16:45.636 [IMP] [COMPILER CLIENT] Received from compiler server - requested build completed
7.12.18 21:16:45.637 [IMP] [COMPILER CLIENT] Auto disconnect from the compiler because it was configured to automatically disconnect when compilation is completed
7.12.18 21:16:45.660 [ERR] Error compiling scripts:
* Scripts/CharacterSkeletons/SkeletonAlphaWolf.cs (line 7)
   Error: 'SkeletonAlphaWolf' does not implement inherited abstract member 'ProtoCharacterSkeleton.ClientSetupShadowRenderer(IComponentSpriteRenderer, double)'
* Scripts/Characters/Mobs/MobDireWolf.cs (line 74)
   Error: 'ServerCharacterAiHelper' does not contain a definition for 'CalculateDirectionToEnemy'
* Scripts/Characters/Mobs/MobDireWolf.cs (line 103)
   Error: 'WeaponState' does not contain a definition for 'InputIsFiring' and no accessible extension method 'InputIsFiring' accepting a first argument of type 'WeaponState' could be found (are you missing a using directive or an assembly reference?)
* Scripts/Characters/Mobs/MobAlphaWolf.cs (line 73)
   Error: 'ServerCharacterAiHelper' does not contain a definition for 'CalculateDirectionToEnemy'
* Scripts/Characters/Mobs/MobAlphaWolf.cs (line 102)
   Error: 'WeaponState' does not contain a definition for 'InputIsFiring' and no accessible extension method 'InputIsFiring' accepting a first argument of type 'WeaponState' could be found (are you missing a using directive or an assembly reference?)
7.12.18 21:16:45.662 [IMP] [Stopwatch] Compiling/loading scripts completed: 3769ms
7.12.18 21:16:45.681 [ERR] Cannot build scripts. Please refer to the compilation errors lists.
7.12.18 21:16:45.731 [IMP] Compiling/loading scripts started...
7.12.18 21:16:45.734 [IMP] Launching compiler process: dotnet F:\Gry\CryoFall\Server\CryoFall_Server_v0.17.7.8_NetCore\Binaries\Shared\Compiler\CryoFall_Compiler.dll --fromGame load
7.12.18 21:16:45.748 [IMP] [COMPILER CLIENT] IPCClient: Named pipe client connecting to COMPILER_at_F--Gry-CryoFall-Server-CryoFall_Server_v0.17.7.8_NetCore-Binaries-Shared-Compiler-CryoFall_Compiler.dll.IPC1234
7.12.18 21:16:45.749 [IMP] [COMPILER CLIENT] IPCClient: Named pipe client connected to COMPILER_at_F--Gry-CryoFall-Server-CryoFall_Server_v0.17.7.8_NetCore-Binaries-Shared-Compiler-CryoFall_Compiler.dll.IPC1234
7.12.18 21:16:45.750 [IMP] [COMPILER CLIENT] Connection to the Compiler Server localhost(IPC):1234 established successfully
7.12.18 21:16:45.750 [IMP] [COMPILER CLIENT] Sending build request: C:\Users\Matek\AppData\Local\Temp\AtomicTorchStudio\CryoFall_v0.17.7\Assemblies\Scripts_release_netcore_x64_crc16533242160812606244 isWarmUp=False forceOverwrite=True
7.12.18 21:16:49.433 [IMP] [COMPILER CLIENT] Received from compiler server - requested build completed
7.12.18 21:16:49.434 [IMP] [COMPILER CLIENT] Auto disconnect from the compiler because it was configured to automatically disconnect when compilation is completed

3
Servers / Re: How to configure the local server?
« on: December 07, 2018, 11:50:15 am »
You need to change all those things by mod where you need to change values in scripts. You need to edit "TechConstants.cs" file to do it.

4
Help section / Server and Mod problem
« on: December 07, 2018, 10:57:41 am »
Hi.
I'm new to modding and programming in general. I'm having problem with testing my mod.
I've made an tool item with texture, recipe, technology and item properties. All done in scripts. I put them together similar to the way i found in working mods that I download and check. I download server i make it running on clean version.
When i first try to run server with mod placed in server and game folders, it didn't have technology yet, and I get error that file is corrupted and it's going to be ignored - server ran without mod. I sayed ok.. let's look what was wrong. I found out that I'm missing technology of this item that will add recipe. So I added script with that.
Of course, all files were putted to mpk file together and placed into the correct folders in it.
After I packed it up again with new script, I tried to launch the server again. But then my server went into the infinity loop and never start :(
Here are all the files: Mod in mpk, mod config, and log from sever loopping.

https://drive.google.com/open?id=1QKZ0aGDngplWC73LrqPogtbPf1Iil72f

Server didn't even showing me wich scripts are making compiler to stop running. There is just empty line, so I don't have idea how to deal with this problem. Maybe I still missing some scripts?
Can someone help me please? :(

EDIT: I fogot to add: after this happend my server and game files are corrupted. I getting error:
https://imgur.com/a/ZxA75Ww

And I need to edit ModConfig.xml again because something is deleting code from it.

5
Ideas and suggestions / Re: SEMI-AUTOMATED BASE DEFENSE SYSTEMS
« on: December 07, 2018, 07:57:28 am »
Yeah for sure, I absolutely agree with it. I just meant that punishing raider just because they're raiding would be pointless, that's all.

6
Ideas and suggestions / Re: A few ideas
« on: December 06, 2018, 07:32:47 am »
I was trying to do a mod with chainsaw yesterday. But i have no idea how to make those files working as a mod.

In my let's call it "mod", I rather add petrol to the recipe, so you can get your hand on this tool while still not unlock full xenology to build rafinery. I was thinking about making it as you said gobias, but it requires too much work with scripts to make it works. Hopefully I would made that mod works soon or devs will maybe added it before me  :P

7
Ideas and suggestions / Re: SEMI-AUTOMATED BASE DEFENSE SYSTEMS
« on: December 06, 2018, 06:55:43 am »
It's sound really stupid to make a turrets that defend your land and then punish more someone who try to raid you... Really stupid idea... It would really kill the game idea of pvp and raid.

8
Ideas and suggestions / Re: A few ideas
« on: December 05, 2018, 04:45:39 am »
Up Up!

I agree, these are nice ideas.

As well as Chainsaw for tier3 od 4 or animals that can be mounted - like horses. A lot of work but in long term might change gameplay.

9
Bug reports / Lower Perfomance while Crafting
« on: December 04, 2018, 04:00:43 pm »
Hello
I'm playing Cryofall for more than week now. I'm playing on community server "[POL] Brodaty Serwer Cryofall discord.broda.tv". I don't know is this problem is the same everywhere or is it only me, but I've discovered that crafting is making weird lags. It's happening when i full up my crafting queue or even when I'm trying to craft something that need more time (like weapons). I'm getting yellow sing in a corner while this ocur but my FPS looks like normal on 60. When I try to moving it's giving me some spike lags. I could live with it but it's kinda make gameplay less attractive.
My PC:
          Operating System: Windows 10 Pro 64-bit (10.0, Build 17134)
          Language: Polish (Regional Setting: Polish)
          System Manufacturer: MSI
          BIOS: C.10 (type: UEFI)
          Processor: Intel(R) Core(TM) i5-6600 CPU @ 3.30GHz (4 CPUs), ~3.3GHz
          Memory: 8192MB RAM
          Available OS Memory: 8132MB RAM
          Page File: 10062MB used, 1661MB available
          Windows Dir: C:\WINDOWS
          DirectX Version: DirectX 12
          Card name: AMD Radeon (TM) R9 380 Series
          Display Memory: 8137 MB
          Dedicated Memory: 4071 MB
          Shared Memory: 4065 MB
          Current Mode: 1920 x 1080 (32 bit) (60Hz)

Maybe it's not a high end PC but I think it shouldn't struglle with the game.
Im sending screens of FPS counter:

https://imgur.com/a/sUuz1BI

https://imgur.com/a/3SsJdRR

Any solution? Does anyone else report such a thing?
Regards

Pages: [1]