Show Posts

This section allows you to view all posts made by this member. Note that you can only see posts made in areas you currently have access to.


Topics - Creat

Pages: [1]
1
Hello again,

wanted to load up Cryofall today to have a look at it, but when/after installing I got a virus detection alert from my scanner (WebRoot), see screenshots.
File location is apparently inside a zip-file (during extraction I assume), the full path is also attached.

I can now verify the game from the launcher, and it says it's fine. If I scan the folder, it's also fine. If I launch the game, scanner kicks in again and prevents the compiler from doing whatever it's trying to do and quarantines it again. Queue me having to re-verify and start again.

I've not white listed the file, but eventually it launched and I'm not in. Weird...

I don't know what the compiler is compiling, but as far as I understand it, especially when run 'interactively' virus scanners tend to listen closely (since it's a way to avoid signature detection). This might be a rather fragile construct, since you probably can't test every version against every virus scanner for every release (I assume).

Screenshots: https://imgur.com/a/1aTsS

I'm off doing some gamin'
Creat

2
Hello,

Quill18 has mentioned a tiny little improvement he'd like to see that I've also thought about (and hoped for) since much earlier versions: Add an indicator for the price-levels in the shop.

Every item (in particular trade goods though) has a "default price" and it can be more or less expensive to buy/sell it in any station. Weather a price is below or above the default price is obviously very important for trading. I'm hoping you could add a small visual indication for the price as part of the symbol/indicator in the shop. It could be a up or down arrow to indicate a higher or lower price, or something like +, ++, +++ and -, --, --- to indicate a slightly, noticeably, significantly higher/lower price, if you are willing to provide a more precise indicator than just a simple above/below the default value.

This would negate the tedium of having to mouse-over every single item (particularly the trade items) to see the how "good" the price in the current station is. It should also be rather trivial to implement this, so I'm really hoping this can be added reasonably quickly!

Thanks!
Creat

3
Bug reports / 1.0.1.b Experience-bar is not displaying correctly
« on: February 02, 2015, 06:16:14 pm »
Contrary to askew1's problem here, I still gain experience just fine, but it's not visualizing it on the "Skills" page. I tried searching this sub-forum and haven't found any mention of this, but as this is my first time playing again in quite a while I'm still not sure if this a new or old issue...

To show what I mean: You can see in the screenshot that the progress-bar essentially shows no progress, while in fact I'm basically a few XP away from the next level. Screenshot!

4
Bug reports / Installation Failed / avast! false positive (?)
« on: August 31, 2014, 06:50:58 am »
Hello,

I wanted to update VoidExpanse today and (once again) the launcher failed to do so. First I was told the 8.4c couldn't be updated (which is fine). It then downloaded the full install, but failes at installing when it gets blocked by my AV (avast). It detects 'Win32:Evo-gen [Susp]' in '50h3pcw4.xmz', located in the folder: ...\AppData\Local\Temp\AtomicTorchLauncher\VoidExpanse_Win_v0.9.9.zip.extract\VoidExpanse_v0.9.9_Win\Server_Mono

Since this file is pulled out from under the launcher, he's understandably upset it's no longer there even though he's just extracted it ;)

I remember there were some troubles with false positives in the past, can I assume this is another one?
What AV-suites do you use on your end to check archives are clean?

Thanks
Creat

5
Game discussion / RSS feed for the development blog
« on: July 07, 2014, 11:41:30 am »
Hello again!

I have recently added the RSS feed for the blog to my feed reader and noticed that the articles aren't properly linked. All articles simply link to atomictorch.com instead of atomictorch.com/Post/Id1065 (as an example). Having a direct linkk would be especially nice when reading on my phone, where navigation is a bit cumbersome...

6
Bug reports / Launcher shenanigans
« on: June 06, 2014, 04:02:59 pm »
Hello, I've got some experiences with the launcher for you. It's basically just a bug report, though I have some general feedback/criticism about that I'll post separately in the near future. In general, I'm very glad there is a launcher that can handle (hopefully) frequent patching in a graceful manner.

So I've got the launcher and downloaded my first version, which happened to be 0.8.0a at the time. I didn't have time to play though, so a day or so later I started the launcher again and was delighted to see that a patch was out and only about 2 MB had to be downloaded (leading to 0.8.2b). Unfortunately, patching failed with a checksum error (or something like that) and I was told to click repair. After that that the launcher was happy that all was good (I don't think anything was downloaded at this point, but I was out of the room for a little while so I don't know).

Forward a couple of hours and I finally have time to actually play. I start the game (via the .exe, not from launcher) and am immediately told that there is a new version. I didn't expect another version to be out again, so I didn't even start the launcher first... I exit, start the launcher and there doesn't seem to be anything new (still showing 0.8.2b and a green checkmark). The game itself displayed the version as 0.8.0 in the main menu, so I thought something had gone wrong, and I clicked on verify files. I'm told my copy is corrupt and it starts downloading the game again, even though there is a perfectly valid path to the current game version already downloaded: The 'downloads' folder of the launcher contains both full 0.8.0a and patch 0.8.0a --> 0.8.2.

If I start the game from the launcher, it's fine (and now it even displays the correct version, only the 'b' is missing). If I start it directly (via VoidExpanse.exe), it will still tell me that there is a new version available on the website (but it also shows 0.8.2 in the main menu), and ask if I want to go download it. Upon exit I can verify files with the launcher just fine though, everything seems to be OK (no checksum errors).
In the properties of the VoidExpanse.exe (on the details tab) I get a version of 4.5.0.18735 at the moment, that wasn't helping in finding out which game version I actually had when problems arose. Might be useful to set this to the actual version of the game ;)

I've uploaded the the log files that the launcher generated to here, but there isn't exactly much specific information in them (please allow small attachments to the forums!).

PS/Sidenote: The whole reason I want to launch the .exe directly is that this is a unity game, and therefore supports '-popupwindow' as a command line switch to start the game in borderless window mode (or rather turns a normal window mode into a borderless one). I have multiple monitors and I usually play with games full-screen on one without the game minimizing upon task switch (so I can use a music player or browser on the second monitor). Since the launcher doesn't allow specifying command line switches (yet?), I'd like to keep doing that. The only thing that seems to break at the moment (well, break is a bit too harsh a word for getting a popup) is that weird version check though, as I assume you disable that with "-fromLauncher"?

Pages: [1]