Author Topic: [Solved] Got a problem: Adding new icons for skills (items were fine)  (Read 1697 times)

BeLugh

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Hi. when i was modding icons for items everything worked fine for me.
But now where i am working on icons for skills i dont get them to work. (I opened a skill icon and changed it appearence liek i did for items).I realized that gimp exported them as 74dpi instead of 96dpi. But even when increase their dpi value to be the same, they are not shown ingame and when you open the skills table, the game crashes (you can only see regular skills, not selfmade ones, they are invisible)

Can i get a hint how to solve this issue? :/ Otherwise i will need to publish first version of my mod without new skill icons.
« Last Edit: August 16, 2014, 10:21:44 pm by ai_enabled »

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1285
    • View Profile
Re: Got a problem: Adding new icons for skills (items were fine)
« Reply #1 on: August 16, 2014, 07:52:06 am »
Hello! The game using texture loader with only two supported formats:
1. JPEG - color/grayscale, not progressive, any compression (we recommend using 85%);
2. PNG - only 24-bit and 32-bit (with alpha). Not 8-bit!
Please be sure you're exporting image in a supported format. Also, if by some reason JPEG is not working, try exporting PNG24/PNG32.
If you still have problems, please upload image for investigation.

Regards!

Hammish

  • Sr. Member
  • ****
  • Posts: 350
    • View Profile
Re: Got a problem: Adding new icons for skills (items were fine)
« Reply #2 on: August 16, 2014, 10:11:11 am »
Can verify that .JPG works just fine for me!  Though I do my icons in slightly lower resolution than the default ones that are in core.cpk (128x128), as the in-engine scaling for the default zoom can sometimes make text look odd through anti-aliasing.

67x67 does the trick perfectly for me on items, and around 62x62 for skills to take into account that they have engine-drawn borders.

BeLugh

  • Jr. Member
  • **
  • Posts: 85
    • View Profile
Re: Got a problem: Adding new icons for skills (items were fine)
« Reply #3 on: August 16, 2014, 12:41:35 pm »
Gimp has automatically progression enabled for jpeg! I had no problems saving png just jpg. It is solved now. Thanks so much!!! :)