Author Topic: Anyone else having problems with Steam not figureing out the game has exited?  (Read 1881 times)

Battlepaw

  • Newbie
  • *
  • Posts: 2
    • View Profile
I installed the game and then changed a few graphical settings, requiring a restart, and used the pop-up to exit the game.    I keep getting the stupid "Game is already running" message from steam, when the application is clearly not running.    I checked for it's process in the task manager, no joy.  I tried restarting steam, didn't do anything.   No way I can fix the issue unless I restart my computer or something I'm guessing.   This is freaking ridiculous.   Has anyone else had the same issue?   

gaara

  • Newbie
  • *
  • Posts: 15
    • View Profile
3 times here ( restart comp needed)

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1564
    • View Profile
Hello!

Thanks for reporting. We've thoroughly investigated the issue but cannot reproduce it here, for both A23 (stable branch) and A24 (experimental).

However, we had similar reports before, mostly for our other games. The game is actually closed (there are no game processes keeping running after the quit) but Steam Client is not detecting it and displaying an error "Failed to start game (app already running)". So this issue is quite old and random. There is a troubleshooting page on Steam website for this issue but it seems to be not helpful. There are some other workarounds such as disabling the Steam Overlay so if the issue happens often, please try it and let us know.

Regards!

Battlepaw

  • Newbie
  • *
  • Posts: 2
    • View Profile
It occurs every time I exit through the menu.   Thankfully I found that logging out of steam and back in seems to fix the issue.  Not sure why.  I'ts still a really annoying issue, though at least I don't have to restart my computer every time I want to relaunch the game.