Author Topic: Unable to launch game [OS X 10.9]  (Read 5969 times)

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Unable to launch game [OS X 10.9]
« on: April 04, 2015, 05:06:53 am »
    I just started playing VoidExpanse yesterday -- it seems like a great game! I am glad that you fixed the rendering bug when you are close to stars. However, with this new update I am unable to launch the game. First, it wouldn't load past the loading screen ("VoidExpanse is loading"), the screen right after the logo. I thought perhaps a restart of my computer would help -- now it won't load past the logo. Any help would be much appreciated! Good work on the game so far!

I am running the game through the steam client, I am on a "mid-2012" macbook pro running on OS X 10.9. If you need any more specifications let me know!

The game version is "v1.2.x"

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #1 on: April 04, 2015, 07:38:14 am »
Hello!
I'm running the game on OS X at home and it works flawlessly, and we've tested the game before release on OS X 10.10 also.
Could you provide the logs from /Documents/AtomicTorchStudio/VoidExpanse/Logs please? Just upload all files from this folder to Google Drive or Dropbox and send us the link.
Regards!

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #2 on: April 04, 2015, 05:05:14 pm »
Thanks for the quick reply! I have uploaded the files to this link: https://www.dropbox.com/sh/ka9xtxxby22sgto/AACmgratr-Dnb7FukIqROpYna?dl=0 . Let me know if you need anything else!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #3 on: April 04, 2015, 05:31:02 pm »
Hello!
I've looked on the logs and unfortunately they not contain any information regarding the issue.
Could you launch the game again please? Wait until it stuck on loading screen, then close game, navigate with Finder (Menu->Go->Go to Folder) to ~/Library/Logs/Unity and upload Player.log on Dropbox. Also upload the new client log file from /Documents/AtomicTorchStudio/VoidExpanse/Logs

I'm really frustrated that the issue appeared after update on 1.2.0, as this update fixes a lot of issues and the players reported it really helps.

Regards!

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #4 on: April 04, 2015, 05:36:47 pm »
Thanks for your help so far! I appreciate it.

There are no more log files being generated, however I did locate and upload the Player.Log file to this link: https://www.dropbox.com/sh/zfg9whquorulyui/AACoYRuz_aBcOZXj_JlrOUdva?dl=0

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #5 on: April 04, 2015, 05:58:42 pm »
    I just launched the game once more, and now it works! Interesting! I even tested my single-player world and it works. I have uploaded the new log files to this location, so that it may help you to figure out what was happening: https://www.dropbox.com/sh/zfg9whquorulyui/AACoYRuz_aBcOZXj_JlrOUdva?dl=0

Thanks for your help!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #6 on: April 04, 2015, 06:07:07 pm »
Thanks for the logs. It's a really weird issue. Investigating...

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #7 on: April 04, 2015, 06:08:21 pm »
Agreed! I appreciate it!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #8 on: April 04, 2015, 06:33:55 pm »
The logs gave me some ideas why it may happens. Seems to be related to the music loading. Did you notice when the last time game stuck on the loading screen do the music start playing or not?
Regards!

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #9 on: April 04, 2015, 06:49:33 pm »
The music did not start playing.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #10 on: April 05, 2015, 12:26:52 am »
Thanks for response!
Working on the fix.

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #11 on: April 05, 2015, 04:11:12 am »
Awesome! Glad I could help!

johnmschneider

  • Newbie
  • *
  • Posts: 17
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #12 on: April 05, 2015, 04:25:05 pm »
I have noticed that this bug does have a reproduction rate. It is over 50%, but if I keep opening VoidExpanse again, it eventually works.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #13 on: April 05, 2015, 06:17:34 pm »
Yes, I was able to reproduce it on my Macbook with GPU auto selection mode - I'm using MBP Retina 15" with two GPU's and if I select with gfxCardStatus app "Integrated only" or "Discrete only" (which I always do) the issue is unreproducible, but in auto mode it sometimes happens. I think the issue happens when the GPU is switched by OS X when the game was launched and loading assets.

Do you also have MBP with two GPUs? If so, could you try gfxCardStatus with forced "Discrete only" mode before launching the game please?

Regards!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1114
    • View Profile
Re: Unable to launch game [OS X 10.9]
« Reply #14 on: April 06, 2015, 04:38:57 am »
Please could you try 1.2.1? We need to verify that the issue is still not fixed.