Author Topic: Crash/Glitch during Galaxy result from Server  (Read 1514 times)

necavi

  • Newbie
  • *
  • Posts: 22
    • View Profile
Crash/Glitch during Galaxy result from Server
« on: May 01, 2015, 05:41:04 pm »
Game version: 1.2.9
Game mode: Multiplayer
Bug Location: Galaxy Map
Steps to Reproduce: Have a mod run relations.SetSystemFaction() while a client is in the Galaxy map. Seems to glitch (shows faction colours with almost no opacity) the first time, then crash the client the second time.
Reproduction Rate: 100%
Logs: http://pastebin.com/Qg4Fcmt1 Note: The galaxy results on times ending in 10 seconds are from the server's script that runs once per minute.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1074
    • View Profile
Re: Crash/Glitch during Galaxy result from Server
« Reply #1 on: May 01, 2015, 08:32:41 pm »
Hello!
Thanks for reporting! Could you upload the mod please?
Regards!

necavi

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Crash/Glitch during Galaxy result from Server
« Reply #2 on: May 01, 2015, 08:48:28 pm »

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1074
    • View Profile
Re: Crash/Glitch during Galaxy result from Server
« Reply #3 on: June 15, 2015, 03:09:23 am »
Sorry for the late reply.
The issue is happens because there are 5 simultaneous galaxy map updates sent to the client. The update sent every time SetSystemFaction() invoked and the game client cannot process these updates properly.
We've fixed it and the update will be available very soon.
Regards!

necavi

  • Newbie
  • *
  • Posts: 22
    • View Profile
Re: Crash/Glitch during Galaxy result from Server
« Reply #4 on: June 24, 2015, 04:31:47 pm »
Thank you! I was very happy to see that one fixed. :)