Author Topic: [SOLVED] No sound on Linux  (Read 4172 times)

cnehren

  • Newbie
  • *
  • Posts: 2
    • View Profile
[SOLVED] No sound on Linux
« on: August 03, 2014, 09:26:48 pm »
Game version: 0.9.4
Game mode: Both
Bug Location: Everywhere
Steps to Reproduce: Start the game, notice no sound
Reproduction Rate: 100%
Screenshot: N/A
Bug Description: There is no sound.  Other applications and other games (many in Steam) are able to play sound.  This system has several soundcards visible, although only one is able to actually produce any audio in this configuration.

I should note that there is no log file anywhere in the directory tree for the game, and there are no error messages printed when I run the game from a shell.  Here's the stdout/stderr for the process:

Set current directory to /usr/home/apeiron/Downloads/VoidExpanse_Linux_x86_v0.9.4
Found path: /usr/home/apeiron/Downloads/VoidExpanse_Linux_x86_v0.9.4/VoidExpanse
Mono path[0] = '/usr/home/apeiron/Downloads/VoidExpanse_Linux_x86_v0.9.4/VoidExpanse_Data/Managed'
Mono path[1] = '/usr/home/apeiron/Downloads/VoidExpanse_Linux_x86_v0.9.4/VoidExpanse_Data/Mono'
Mono config path = '/usr/home/apeiron/Downloads/VoidExpanse_Linux_x86_v0.9.4/VoidExpanse_Data/Mono/etc'

I have Mono version 3.2.8 installed.  I'm able to run a single player game, so it seems to work, but if it's involved in sound playing that part is broken.
« Last Edit: August 04, 2014, 09:04:15 am by ai_enabled »

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1929
    • View Profile
Re: No sound on Linux
« Reply #1 on: August 03, 2014, 09:47:06 pm »
Hello! Thanks for reporting!
Log location is "~/.config/unity3d/AtomicTorch.*/.*/Player.log
It's a common issue with Unity3d games under Linux. Please try solution posted here.
Regards!

cnehren

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: No sound on Linux
« Reply #2 on: August 04, 2014, 05:19:58 am »
Thanks for the pointer to the log location--this helps.  It turns out that I needed the 32bit version of the pulseaudio library. I installed my vendor's package for the 32bit pulseaudio library and now I have sound! \o/

kyokei

  • Sr. Member
  • ****
  • Posts: 475
    • View Profile
Re: No sound on Linux
« Reply #3 on: August 04, 2014, 06:27:28 am »
Another linux'er... joy! I don't feel alone anymore now :)