Author Topic: Game Still wont Run in ubuntu  (Read 3917 times)


  • Newbie
  • *
  • Posts: 3
    • View Profile
Game Still wont Run in ubuntu
« on: April 04, 2015, 12:03:58 pm »
All i get is a brief glimpse of the loading screen. I check around at the others having what seems to be this issue and ran every command that was posted for linux compatibility but it dose not seem to have done anything.

Game version:  1.2.0
Game mode:  it wont get me that far
Bug location:  start of game
Steps to reproduce:  every time I start up
Reproduction rate: I have not produced anything but this bug
Screenshot:  can you imagine seeing the loading screen for 3-5 seconds then crash to desktop?
Bug description: game no wanna run even after all the compatibility stuffs I ran

Here is the most recent log file:

4.4.15 11:46:30.9601 [IMP] Log file opened
4.4.15 11:46:30.9845 [IMP] VoidExpanse game client runtime v1.2.0
AtomicTorch Studio (c) 2013-2015
All rights reserved.
4.4.15 11:46:30.9999 [IMP] Operations timed using the system's high-resolution performance counter.
  Timer is accurate within 100 nanoseconds
  Timer frequency in ticks per second = 10000000
4.4.15 11:46:31.0049 [IMP] Initial screen state: 1366x768@60 Fullscreen
4.4.15 11:46:31.2262 [IMP] System info:
OS: Linux 3.13 Ubuntu 14.04 64bit
CPU: AMD E2-1800 APU with Radeon(tm) HD Graphics (cores 2)
RAM: 3536Mb
GPU: Gallium 0.4 on AMD PALM (512Mb VRAM, shaders 30, shadows=yes, stencil=yes)
Screen resolution: 1366x768 (HiDPI=no)
Launch command line: /home/brigand/.local/share/Steam/steamapps/common/VoidExpanse/VoidExpanse
Current path: /home/brigand/.local/share/Steam/steamapps/common/VoidExpanse
Static data path: /home/brigand/.local/share/Steam/steamapps/common/VoidExpanse
Dynamic data path: /home/brigand/Documents/AtomicTorchStudio/VoidExpanse
Texture loading plugin supported: yes
4.4.15 11:46:31.5881 [IMP] The settings file loaded successfully
4.4.15 11:46:32.0721 [INF] The configuration file saved successfully.
4.4.15 11:46:32.0771 [IMP] Core folder: "/home/brigand/.local/share/Steam/steamapps/common/VoidExpanse/Core"
Mods folder: "/home/brigand/Documents/AtomicTorchStudio/VoidExpanse/Mods"
4.4.15 11:46:32.3032 [IMP] Cache root path: /tmp/AtomicTorchStudio/VoidExpanse
4.4.15 11:46:32.3202 [IMP] Steam subscribed mods count: 0
4.4.15 11:46:32.3657 [IMP] Virtual file system init with core mod file path:
Mods file paths:
4.4.15 11:46:32.5412 [IMP] Virtual file system initialized successfully:
Core mod: core
Mods list:
   --no mods--
Total files count: 2365
4.4.15 11:46:33.3124 [IMP] Reloading XML data for XmlLanguagesProvider. Data validation is: disabled
4.4.15 11:46:33.3494 [IMP] Xml data loading result: success
Loaded objects types:
languagedefinitions: 2

4.4.15 11:46:33.5240 [IMP] Current language: en_us
4.4.15 11:46:34.0620 [IMP] Stopwatch localize xmls: 523.29ms
4.4.15 11:46:34.0651 [IMP] Localization: total 93 XML files localized
4.4.15 11:46:34.0657 [IMP] Localization initialized for language en_us
4.4.15 11:46:34.0702 [IMP] Reloading XML data for XmlDataProvider. Data validation is: disabled
4.4.15 11:46:34.7241 [IMP] Stopwatch loading xmls: 599.75ms
4.4.15 11:46:34.7796 [IMP] Xml data loading result: success
Loaded objects types:
asteroids: 6
characters: 8
skills: 106
itemboosters: 15
itemconsumables: 8
itemdevices: 12
itemengines: 8
itemfueltanks: 6
itemgenerators: 7
itemgrapplers: 5
itemhulls: 27
itemstatics: 17
itemresources: 12
itemradars: 6
itemrcss: 6
itemshields: 12
itemweapons: 58
spacestations: 5
jumpgates: 1
trails: 12
spaceobjects: 9
topics: 72
npctypes: 58
crates: 3
visualeffects: 5
decorations: 4
itemlists: 12
factions: 6
playlists: 24
specialobjects: 2

4.4.15 11:46:34.7817 [IMP] Physics FPS set to: 20; Input Cursor update rate per second set to: 20
4.4.15 11:46:34.7935 [IMP] Current log severity: Important
4.4.15 11:46:34.8001 [IMP] UnityApi was reset
4.4.15 11:46:35.2690 [IMP] Achievements givers initiated. Total 4 givers.
4.4.15 11:46:35.2692 [IMP] Unable to load game stats and achievements: Stats.db file is not available at /home/brigand/Documents/AtomicTorchStudio/VoidExpanse/Stats.db
4.4.15 11:46:35.3626 [IMP] Command binding completed successfully. Total binded commands count: 264.
4.4.15 11:46:35.5749 [IMP] GameClient: Modules Master, Auth, Chat, Items, Misc, Player, World, Dialog, Singleplayer, Device, SpaceStation, Party, Core initialized
4.4.15 11:46:35.7424 [IMP] MasterServerClient: SocketClient: Socket-client trying to connect to: (UDP)
Connecting timeout: 5s | Connection timeout: 13s
4.4.15 11:46:36.0146 [IMP] MasterServerClient: SocketClient: Socket-client connected to: (UDP)
4.4.15 11:46:36.0147 [IMP] MasterServerClient: Connection to Master Server established successfully
4.4.15 11:46:36.1786 [IMP] StatesManager: total 24 states: CharacterCreation, ConnectionDropped, Console, ContainerExchange, GameEnd, GameOver, Gameplay, Help, InGameMenu, LanguageSelection, Loading, LocalServerFatalError, Logo, MainMenu, MasterLogin, MasterUsernameSelection, ModsSettings, NpcDialog, OnlineUsers, Options, PlayerMenu, PlayerShipRespawned, SpaceStation, Tutorial
4.4.15 11:46:36.1904 [IMP] Primary state changed to Logo
4.4.15 11:46:36.1951 [IMP] Primary state opened: Logo
4.4.15 11:46:36.1980 [IMP] State became active: Logo
4.4.15 11:46:36.2105 [IMP] FxManager initialized
4.4.15 11:46:36.2492 [IMP] UpdateMusic(): state=Logo
4.4.15 11:46:36.2596 [IMP] UI antialiasing switched to PPAA
4.4.15 11:46:37.1458 [IMP] UI base size changed: 1024x768; scale=1.00
4.4.15 11:46:37.2282 [IMP] AvatarsCache released
4.4.15 11:46:37.2498 [IMP] TextureCache released
4.4.15 11:46:37.2786 [IMP] ModelsLoader and Materials cache cleared
4.4.15 11:46:37.3051 [IMP] UnityApi was reset
4.4.15 11:46:37.4185 [IMP] CustomThreadPool ClientThreadHelper started with 100 total threads, 2 active threads max.
4.4.15 11:46:37.4193 [IMP] UI antialiasing switched to PPAA
4.4.15 11:46:37.5532 [IMP] Applying all client settings
4.4.15 11:46:37.5725 [IMP] Set resolution invoked 1366x768
4.4.15 11:46:37.5749 [IMP] Screen resolution change no need to 1366x768
4.4.15 11:46:37.5806 [IMP] Set Display mode invoked: go to Fullscreen
4.4.15 11:46:37.5868 [IMP] TEXTURES REFRESH STARTED!
4.4.15 11:46:37.5967 [IMP] Quality level changed to Level4 (Level4)
4.4.15 11:46:37.6068 [IMP] Frame limit setting: VSync; TargetFrameRate: -1; vSync count: 1
4.4.15 11:46:37.6114 [IMP] Set anti-aliasing setting: MSAAx4
4.4.15 11:46:37.6154 [IMP] UI antialiasing switched to MSAA
4.4.15 11:46:37.6231 [IMP] Color blind mode: Off
4.4.15 11:46:37.6302 [IMP] Applying AutoPauseSingleplayer: True
4.4.15 11:46:37.7786 [IMP] Loading XAML control: Assets.UI.Logo
4.4.15 11:46:37.7794 [IMP] States cache is null
4.4.15 11:46:37.8668 [IMP] ScreenActual size changed: 1366x768 (coef=1.00)
4.4.15 11:46:37.9560 [IMP] UpdateMusic(): state=Logo

Please fix!!! This game looks pretty sweet, I would rather you keep the 15 buxs I paid for it  :D


  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1929
    • View Profile
Re: Game Still wont Run in ubuntu
« Reply #1 on: April 04, 2015, 05:41:08 pm »
Usually it's a driver-related issue. Could you update on the latest AMD proprietary GPU driver please?
The PC specs is below the minimum game requirements, however it should at least launch and show menus, and you will be able to play on the low resolution with low graphics settings.

Also it seems some libraries may be missing. To determine what libraries are missing please execute:
Code: [Select]
ldd ./VoidExpanseand
Code: [Select]
ldd /VoidExpanse_Data/Plugins/x86/libNoesis.soand
Code: [Select]
ldd /VoidExpanse_Data/Plugins/x86/ And post output of these commands here.



  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Game Still wont Run in ubuntu
« Reply #2 on: April 04, 2015, 08:38:35 pm »
brigand@brigand-X55U:~$ ldd ./VoidExpanse
ldd: ./VoidExpanse: No such file or directory
brigand@brigand-X55U:~$ ldd /VoidExpanse_Data/Plugins/x86/
ldd: /VoidExpanse_Data/Plugins/x86/ No such file or directory
brigand@brigand-X55U:~$ ldd /VoidExpanse_Data/Plugins/x86/
ldd: /VoidExpanse_Data/Plugins/x86/ No such file or directory

mabey thats an issue.


  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Game Still wont Run in ubuntu
« Reply #3 on: April 04, 2015, 08:55:03 pm »
Using Ubuntu 14.10 64 bit, I experienced a crash at the same point (during loading screen, right after AtomicTorch logo displayed) at first.

I followed (er, tried to anyway) the instructions here:

The instructions call for installing ia32-libs from the Ubuntu Raring repository (Ubuntu 13.04) which does not work on Ubuntu 14.10 because "ia32-libs" is no longer in the repositories for this version. As a result, the following error was displayed by apt-get on the command line:

Code: [Select]
Package ia32-libs is not available, but is referred to by another package.
This may mean that the package is missing, has been obsoleted, or
is only available from another source
However the following packages replace it:
  lib32z1 lib32ncurses5 lib32bz2-1.0

After doing "sudo apt-get install lib32z1 lib32ncurses5 lib32bz2-1.0", the game launched and ran without any further errors.

It may be the case that only one of those three libraries was needed to run the game, but I installed all three just to see, and they do not appear to conflict with anything so far.

I'm not sure if this is the same issue, but it may be worth a go.
« Last Edit: April 04, 2015, 08:58:22 pm by harrisclinton »


  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Game Still wont Run in ubuntu
« Reply #4 on: April 04, 2015, 10:28:11 pm »
yeah i tried that for x64. Fresh install, drivers are ok.

So far this is the only game for ubuntu I've had an issue with


  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1929
    • View Profile
Re: Game Still wont Run in ubuntu
« Reply #5 on: April 05, 2015, 08:55:38 am »
Thanks guys!
We're going to provide 64-bit version of the game and also resolve dependency with Mono in the future releases. I can't say exact date when we will be able to do it as the game uses NoesisGUI for UI which is currently 32-bit only (on Linux), but the developers tell us they're working on 64-bit version
 We're really excited about the reception of the game within Linux players (we was in Steam top sellers on Linux for some time), so we do our best on resolving these issues as soon as possible.


  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1929
    • View Profile
Re: Game Still wont Run in ubuntu
« Reply #6 on: April 23, 2015, 11:42:44 pm »
VoidExpanse v1.2.9 should run fine for you. Have you tried it?