VoidExpanse > Help section

Collider hangs main Thread question?


Hi, I got this physics issue in my server. I am trying to push for a release of a basic Station Interior Mod but right now Id be releasing with a bug that crashes the server... Im not sure exactly why it does that. If anyone can help please.

I might have fixed the problem. It seems that even though there are no mining stations in the starting system, that the collider collisions are still passing through the physics check even though no players are in the systems where there are mining stations.

I've setup the mining station interior colliders so that no polygons touch any other polygons. I will keep testing tonight but it hasn't crashed for a while now.

Nevermind, again, the bug is still there. I thought it was the miner squads beeing spawned on top of each other or on top of the station colliders but it doesn't seem to be the issue.

Finally, it wasnt even the squad miners beeing spawned . They arent even touching the station colliders when spawned. The problem really is the station interior colliders. I have decided to refactor all station interior Polygon colliders so that they do NOT touch any other types of Colliders, they are completely separated. I don't even know what actually is the problem on this one so I'm just going with my guts feeling. It really feels like a needle in a haystack though... Not even sure if this is finally going to fix this crash.

Is it possible to know which type of Physics library is/was used for Void Expanse? I would like to search on the forums of that library to see what do to/not to do, at least it would tell me what Im doing wrong.

EDIT: Farseer Physics - as per this thread here https://steamcommunity.com/app/324260/discussions/0/594820656472604635/

i am thinking of releasing version 2.3.1 with non-destructible stations to start off. But i can't release it now. i have finally found the issue which i gave up on 9 months ago on everything because of this. i had a hunch it was that but i thought my code was fine.

I can't release it now because the issue was the turrets i was spawning right next to stations. removing those turrets fixes the saving issue i had last year in june 2019 approx. i am sorry i gave up because of that, but i am glad i have found the courage to dive back in. But i only tried it earlier today and it worked, the first save passed though. I will recheck the code tonight. The Farseer physics was fine and i owe probably an apology to them thinking it was their engine the issue. it seems i am having doubts in them when i should be having more doubts in me. but i am happy. it works.


[0] Message Index

Go to full version