CryoFall > Bug reports

Local Server not saving when closing out

(1/2) > >>

Zaez_Cerebrate:
I'm trying to run my own local server, but when I close out of the game it doesn't automatically save. It runs the command line just fine and says it's saving, but when I reload the server it's just putting me back to my previous point. The autosave function works fine I believe. Any advice or ideas?

ai_enabled:
Hello!

There were two reports when the autosave didn't work and both times it was due to the lack of RAM on the PC. The game server requires additional 900-1000 MB of RAM to operate properly. Could it be the case?

To check whether the save feature actually works and the issue is only when closing the server window, please try saving manually by typing "save" or "stop" (without quotes) in the server console and pressing Enter.

Regards!

Zaez_Cerebrate:
Manual saving did the trick! I'm not sure why, but whatever xD I'll definitely take the added ability to manually save it instead of just desperately hoping that it saved all my stuff too xD Thanks, AI! Have a great day!

ai_enabled:
Ok, so the issue is only when you close the server window. Probably it has not enough time to save the world completely before it's getting killed by Windows, hmm.
In the near future we're going to properly integrate the local server right in the game (so there will be no separate console window).

Regards!

Zaez_Cerebrate:
Sounds wonderful! And I tested it a few more times. I can indeed confirm that it works best when I manually type 'save' in the command box. Is there any diagnostic info I can give you to help your troubleshooting in case you come across this again?

Navigation

[0] Message Index

[#] Next page

Go to full version