Author Topic: Problem on modded server, PVP enabled but players can't attack each other  (Read 942 times)

MightyMonte88

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
No matter what weapons they used, modded or not, different ammo types, melee, they can cause status effects to one another ( bleeding) but can't deal damage.

Turrets won't shoot at enemy players either, no matter the settings

PVP is enabled, friendly fire is not ( we even went to war in the factions menu to be sure )

What about this value
#DamagePvpMultiplier: 0.4

We removed the #, nothing changed

It's worth noting, that we launched the server in PVE mode accidentally at first, and then switched it to pvp without wiping. Is that the source of the issue?
« Last Edit: January 24, 2021, 07:27:14 am by MightyMonte88 »

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1962
    • View Profile
Hello!
You need to restart (stop and start) the server after editing the ServerRates.config.
If the issue persists, please provide the server log to let us investigate the issue (upload to any file hosting service and share the link) in a private message.

Quote
Is that the source of the issue?
No, changing the server from PvE to PvP works properly.

Regards!

Khaos

  • Jr. Member
  • **
  • Posts: 54
    • View Profile
I server has been stopped and reloaded, after changing the settings. I changed the settings saved the file and then stopped and started the server. I do not however close the screen I just used the dotnet command with load at the end. Should I have totally closed the program?

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1962
    • View Profile
@Khaos, it's not required to close the console window. Sounds like you've done it right.
I guess something is odd with your mod code.
Anyway, please upload the server log.

Regards!


ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1962
    • View Profile
The logs look ok. Ok, I have a better idea. Please drop me in a PM an archive with: mod, modsconfig, server rates config. I will run a debugger with two clients and one server.

MightyMonte88

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Will do, i'll have it to you within 15 minutes, the files aren't large, my connection is just slow since i live in a rural area

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1962
    • View Profile
Apparently, there is a bug in our source code when DamageFriendlyFireMultiplier is not 1. We didn't test it enough and nobody before tried this setting in A29.
We will provide a server fix with the next patch. Meanwhile, please set DamageFriendlyFireMultiplier to 1.

MightyMonte88

  • Jr. Member
  • **
  • Posts: 60
    • View Profile
Wow that was unexpected, at the very last im glad we were able to help identify a bug, thank you so much for your time Ai.  :)