VoidExpanse > Bug reports

Unable to start single player after doing a fresh reinstall to 0.8.4c

(1/1)

Hammish:
Joining a multiplayer works fine.  Trying to start up a single player, I see the local monoserver process start up briefly and then close.  Here are the logs:

https://www.dropbox.com/s/sir8vm1xoun5ixe/Log_VoidExpanse_Client_2014-06-30_12-18.log
https://www.dropbox.com/s/1d3uttepkfrul3k/Log_VoidExpanse_Server_2014-06-30_12-18.log

If the new version coming soon will fix the issue, though, feel free to let me know that.  I can be patient. :)

ai_enabled:
Please remove ModsConfig.xml file near game executable file and try again (there are may be conflict with it).
Also try to temporary shutdown firewall/antivirus - by logs it looks like client was unable to establish connection with the singleplayer server (it uses UDP port 12345 on localhost for it). Usually it means that something is blocking this connection.
Regards!

Hammish:
Tried both of these, didn't seem to have an impact on it. :|

Just to be sure I went ahead and installed both virus and firewall exceptions for both voidexpanse.exe and AtomicTorch.SpaceRPG.Server.R untimeWin.exe (which is the server, yeah?) and added a local path for UDP 12345.  Still didn't seem to help; from what I could see in my process list the main .exe was trying to launch the server process, the server process launched (very, very briefly) and then closed, thus the inability to connect to it.

At this point I tried to launch AtomicTorch.SpaceRPG.Server.R untimeWin.exe by hand, much like launching a server for multi, and here's what I got:



Not really sure if this helps or not.  All I did was enter 'new' for a new world and then all the rest came.

ai_enabled:
Thanks for the report! Fixed, and will be in the next release, which is coming soon!
Regards!

Navigation

[0] Message Index

Go to full version