[0.96c] Slaver kidnap mission problem / incompletable

Started by Rhywden, August 17, 2014, 07:37:05 AM

Rhywden

Version: 0.96c SP

I got the mission to rescue some NPC from slavers from an Order officer early on. Shortly after exiting the station, I got the message: "The slaver ship has been destroyed. Now I have to search the wreckage for survivors." with the mission pointer pointing back at the station.

However, all 3 slaver ships were still there upon my arrival. I also could hail the named pirate ship but the dialog option did not work. Destruction of the ships also didn't yield the item for the mission which leaves the mission in an incompletable state.

Logs and Save files here (in the folder 0.96c):
https://www.dropbox.com/sh/460n29v7x2z24mp/AAAvCaXbU5QqTOyQdEdJ3V8Pa

ai_enabled

Hello! Thanks for reporting, will be fixed soon. Some issues with quests expected in the experimental 0.9.6c build. If you have any other quests issues please report.
Regards!

ai_enabled

Fixed with v0.9.7c. Not tested in-game yet, so if anyone can confirm bug gone - we would be very grateful ;) .

Rhywden

Sorry, it's not fixed with 0.97c (the latest version available).

Same issue - while I was on my way to the rendezvous directly after taking the mission, I again got the notification that "I now have to search the wreckage".

ai_enabled

Thanks for reporting. This quest will be tested fully and fixed with next release.
Regards!

jerkyhorseman

Quote from: Rhywden on August 19, 2014, 01:03:21 PM
Sorry, it's not fixed with 0.97c (the latest version available).
Same issue - while I was on my way to the rendezvous directly after taking the mission, I again got the notification that "I now have to search the wreckage".
I think the latest version has worked very well.