AtomicTorch Studio Forums

VoidExpanse => Bug reports => Topic started by: ninekorn on May 03, 2019, 05:02:16 pm

Title: Colliders Server Thread Aborted crash?
Post by: ninekorn on May 03, 2019, 05:02:16 pm
Hi,

Here is the image of the current bug I am facing. Is it due to too many colliders on the same object?

(https://i.ibb.co/18YYTSt/station-Interior-Bug.png)
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on May 04, 2019, 04:22:12 am
Hi,

this is really strange. The physics collision test took over 9 seconds or so, this is an extreme case.
If this issue is reproducible, you need to try to simplify the physics.
Please note that it's always a good idea to use simple shapes (rectangles and circles) instead of polygons.

Regards!
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 16, 2019, 12:26:12 am
I didn't remember that I originally had posted this thread here. I am still having some issues it seems. I have removed ALL polygon colliders of all XML station Interior files. But it did crash again with the same thing. What could be causing this issue. I mean i am on some or all stations using more than 30 colliders combined. I can't really lower that number unless I refactor all of the station interiors but again I don't even know what to model them too because I don't know where the bug is coming from. I am re-testing tonight with ALL polygons removed but its a needle in a haystack. I mean all stations have a concave shape but no colliders themselves are concave since I am now using only circle colliders mixed with Box Colliders. Only the mining station and science station have circle colliders, all of the others have box colliders ONLY.
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 17, 2019, 01:30:32 am
Hello!
Please share the screenshots of the error, probably there is another error and you're looking in the wrong direction.

Regards!
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 17, 2019, 01:52:41 pm
got another screenshot here. The error at the top has a different syntax.

(https://i.ibb.co/jMSBP77/error-Collider.png)
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 17, 2019, 01:58:30 pm
Hmm, this is weird. Please upload the MPK file and share the link, I will take a quick look.
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 17, 2019, 02:18:20 pm
The file is here:
https://drive.google.com/open?id=1U6Cb9a3whCSIhQdS13sKkiUPodK5ZdfT
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 17, 2019, 08:28:55 pm
Hi,

I was so frustrated about this bug yesterday that I had put that station Interior projekt on the shelf. So today I rebuilt the drone MOD completely WITHOUT the station interior but forgot to remove the custom spawning of the turrets... The server console went red again with somewhat of a similar crash with the main thread hanging... I didnt take a screenshot but that might mean that the problem is coming from the script where i am spawning the turrets and where I am spawning the repair/refuel platforms, in the script "BaseGenerator.js" .I have commented out all of that code and will keep testing tonight... I really hope a thousand percent that the mistake is mine somewhere in that code, it would mean that i will be able to find it and fix it.
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 17, 2019, 10:05:39 pm
Very sorry for the commotion about this. It seems that the problem really was on my end. Sorry for "snatching" you from Cryofall to look into this but it seems as it turns out, this turn of events made me find the bug. It really seems to be in the scripts basegenerator or NPCGenerator where the turrets are spawned that the bug is and it's my fault. But I must admit, now that the station interior mod is rolling, not yet updated on steam, and that I can finally spawn drones at will, the development can continue. thank you

EDIT: 2019-06-18 - 02h57am - Nevermind... the crash is still there...


EDIT: 2019-06-18 - 02h57am -All of the station colliders had a mass of 8. I changed that to 1. The drones colliders were 1000 of mass, i changed that to 1. I removed the turrets and repair/refuel platforms from spawning. testing now for stability .

And after doing that I got this error.

(https://i.ibb.co/5GHhzpg/error.png)


Also I am using a hull that has absolutely no vertices and no faces and use it for the NPC At Base. I just removed it for testing.
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 21, 2019, 03:15:23 am
Hello!

I've checked your MPK source code and it doesn't have any polygon-shaped colliders used anywhere.
Are you certain you're using only this MPK and your Core.cpk is not modified?

We're using polygon physics to define physics for some asteroids (probably all asteroids), hulls (though only a few of them), and stations in Core.cpk. So the issue might be related to our physical shapes having a calculation problem when they collide with the physical shapes you've defined in your mod.

I will try using your MPK to try to locate the issue.

Regards!
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 21, 2019, 04:27:17 am
I've tried your MPK but I cannot reproduce any issues. It works flawlessly here as far as I've tested (flying in shuttle around and inside the first base).

Please let me know any exact steps I could use to reproduce the issue.

Also, please pay attention to the "physics_ms" performance stat in the game log. If it's going much higher than 1.00 milliseconds something is probably wrong.
(http://i.imgur.com/CGnJr7g.jpg) (https://imgur.com/CGnJr7g)
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 21, 2019, 06:45:46 am
Hi ai_enabled,

Thank you for investigating. The bug is not happening at a precise moment. It can happen at 30 seconds gameplay or at 10 minutes gameplay for no apparent reasons. I removed all of the polygon colliders from the station interior xml files, I removed the turret spawning and repair/refuel platforms spawning and still, the bug was apparent. I have got no clue on what is creating the error.

I have just released the part 2.0 of 9.0 of the 9sMODs series without the station interior, but I am still using 8 different rotations for all stations. It seems that the bug is not apparent when I am only using the original station colliders... But also, I made sure to use the original copies of the station XML files with only modifying their name and rotation and size. Next, I will try to reincorporate one by the one the station interiors to see if it can handle it. Thank you again,

Don't continue testing as again, its a periodic bug that happens and I have got no clue on how to reproduce it faster. You will lose time working on Cryofall if you start playing Void Expanse just for this bug. When I will have a more pinpoint way of knowing where the bug comes from, I will update the thread here.
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 21, 2019, 06:57:31 am
I see. So the issue is random...
Ok, please let me know if you will stump on it again and then send me your latest server log file to check.

Regards!
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 21, 2019, 08:22:29 am
Hi,

I have just tested again with the station interior and somehow, the crash only happened once I changed system. Here are the logs. Could it be that jumpgates or turrets jumpgates are spawning inside of the station colliders?

https://drive.google.com/open?id=1nm59bY0oZ748a6k519PZgSvJHM6Gpby6
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 21, 2019, 09:38:44 am
Yes, it's very likely to be related to the distance from stations to asteroids and any other objects (which are using polygon shapes to define their physics).

I've tested the MPK you've uploaded but with it, I cannot reproduce any issue when I teleport to other systems (tested several star systems).
Title: Re: Colliders Server Thread Aborted crash?
Post by: ninekorn on June 22, 2019, 11:11:25 pm
Could it also be the way that I am "exporting" the models out of Blender that could affect the collider generation inside VoidExpanse?
Title: Re: Colliders Server Thread Aborted crash?
Post by: ai_enabled on June 23, 2019, 07:33:18 am
No, the 3D models are not used in any way on the server side.
Only the defined in XML physical shapes are used.

Regards!