Author Topic: Updated server to 0.26 - now player hang when joining server  (Read 144 times)

gravyrobot

  • Newbie
  • *
  • Posts: 3
    • View Profile
Updated server to 0.26 - now player hang when joining server
« on: April 23, 2020, 09:09:49 am »
I run a private server at my home for my son and I to play on.  After my steam client updated, I was no longer able to join my cryofall 0.25 server, so I attempted to update it.  Now, when players attempt to join the server it will "hang" and you will never enter properly.  Any help you could provide would be very helpful!  I'm thinking that I've messed up the upgrade process somewhere along the way.

My setup:
I am running the docker container on my kubernetes cluster with persistent storage.
The container version I am running is atomictorch/cryofall-server:0.26

When my server starts up I do receive an exception:

23.4.20 16:03:43.651 [ERR] Unhandled exception in Server game loop
System.Exception: There is no existing valueTypeMetaType
   _____________________________ ________stack trace________________________ _____________
   at SchemeFieldType.GetExistingVa lueTypeMetaType()
   at ObjectMetaTypeSpecificationHe lper.GetSchemeFieldTypeEntry(schemeField)
   at ObjectMetaTypeSpecificationHe lper.GetFieldEntry(metaField)
   at ObjectMetaTypeSpecificationHe lper.GetFieldsEntries(specification)
   at ObjectMetaTypeSpecificationHe lper.WriteSpecification(entries, specification)
   at ObjectMetaType.WriteMetaTypeS chemeSpecification(entries)
   at SchemeMetaType..ctor(metaType)
   at <>c.<.ctor>b__3_0(m)
   at SelectListIterator`2.ToList()
   at Enumerable.ToList(source)
   at SerializerScheme..ctor(serializerMetaTypes)
   at Serializer.GetScheme()
   at BaseSerializationProvider.#=zDNp1DTvzgJJ5(#=zQERLKz4=)
   at BaseSerializationProvider.#=zeL00b3$76amB(#=zQERLKz4=)
   at #=zh636y$XUZkHVOKX1DHeAwVKUrlqBzbnMszBiEolSQzRa.#=z$8MTJY_WvF8$(#=zVe_qwudg9NWD, #=zNmgRgbzDWwhTtIPcvA==)
   at #=zvjO2XfKi05jikJdYaw==.#=zPmfJuJF1Tv0ISueEIw==()
   at #=zrLHl_PqjspilGdmBHnnCzZiMq6p1CR4Q0w==.#=zHtHfQrOUngGfzhH2$w==()
   at #=zkFdjxHuqoEyY521S5VR_rdMcs$nDyUcL5hMAI0o=.#=zrkRVrP4q3$ED()
   at #=zcVuKr4qtTXqCkaSdNTFuVzzgsv71FChG_g==.#=zk_Q7Al8=(#=z3vods5o=)
   at #=zcVuKr4qtTXqCkaSdNTFuVzzgsv71FChG_g==.#=zAaQkFVjWOZxx(#=z3vods5o=)

When my client joins I receive the following exception:

23.4.20 16:06:35.467 [IMP] Connection established
  #10.244.2.1:11820 UDP
23.4.20 16:06:35.808 [IMP] MasterServerClient: Sending Command CheckToken_7 (ID=0)
23.4.20 16:06:35.811 [IMP] [Auth] Asking Master Server to check connection token
  #10.244.2.1:11820 UDP
23.4.20 16:06:35.892 [IMP] MasterServerClient: Received Command CheckTokenResult_8 (ID=3818)
23.4.20 16:06:35.913 [IMP] [Master] Master Server check connection token result received: isAuthenticated=True isAllowed
=True
  #10.244.2.1:11820 UDP
23.4.20 16:06:35.914 [ERR] Error occured in command processing Command CheckTokenResult_8 (ID=3818): unknown error
System.NullReferenceException: Object reference not set to an instance of an object.
   _____________________________ ________stack trace________________________ _____________

   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zi2Gaq$sjPSqC74uszbfELnHEylG7(#=zs2e9WYY=)
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zgiEdxQ01ReAAKa3c6FtWlaycjHaO(#=zs2e9WYY=)
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zNsHOVZ9p6AEhI1s2e1ot6672Q4LwBlnYPs5BOCEtKkyK()
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zfuHBL1DtVwALRhYcXdGFU_dHkHYj(#=zs2e9WYY=, #=znbO3GxA=)
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zVIMuOOHwCFIBxXMp4vG3kD4sRdbVxRkZrVeztXA=(#=zs2e9WYY=)
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zzHPxg6wQL7TX7dVdWHywPVjzSs140sih2aNExAY8hLQ5(#=zs2e9WYY=, #=znb
O3GxA=, #=zoZp8Mdk=, #=zrxN0B88=)
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=zoLn7KxJ0mcmwlf3tPtTNhPE=(#=zs2e9WYY=, #=znbO3GxA=, #=zoZp8Mdk=,
 #=zrxN0B88=, #=zu65iGSQ=, #=z9tIX0Xg=)
   at #=qrQlUip5Q0MLOmQPOBPnx7u0IpdY1671kUeKH7xN1Ay0=.#=z__lTOEEKYNckqZkOgOFCZ69Dbcjd(#=zs2e9WYY=, #=znbO3GxA=, #=zoZp8M
dk=)
   at #=zlWYBAK3cK1CeUBOPssCLgsjsNrxdD_Lo9Q==.#=zfEv5hucpfeYkbDBZkQ==(#=ztNtvlPA=)
   at #=zlWYBAK3cK1CeUBOPssCLgsjsNrxdD_Lo9Q==.#=zHJzl0Xk=(#=ztNtvlPA=)
   at #=zc5ElUVFRE7slBFmo8FtAwC74Wml3p6eRn_Myznk=.#=zHJzl0Xk=(#=zTokuprk=)
   at #=zcVuKr4qtTXqCkaSdNTFuVzzgsv71FChG_g==.#=z2YM03KLQprqo(#=ztNtvlPA=)
   _____________________________ _____________________________ ___________________________

Is there something in the persistent data that needs to be adjusted or deleted?  Thanks in advance for any help you might be able to provide.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1555
    • View Profile
Re: Updated server to 0.26 - now player hang when joining server
« Reply #1 on: April 23, 2020, 09:11:38 am »
Hello!

This update requires the savegame wipe as I've explained here in the first comment https://steamcommunity.com/app/829590/discussions/7/3264459260603005606/

If you don't want to update you can keep using A25 server and switch the client to the "a25-stable" branch in Steam Client (game properties -> "BETAS" tab).

Regards!

gravyrobot

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Updated server to 0.26 - now player hang when joining server
« Reply #2 on: April 23, 2020, 09:16:10 am »
I missed that second comment in your post where removing the savegame folder is required.  Thanks for getting back to me so quickly I really appreciate it.  I'll wait to discuss with my son if he wants to start over with a new save or run on a25-stable.  Thanks!

gravyrobot

  • Newbie
  • *
  • Posts: 3
    • View Profile
Re: Updated server to 0.26 - now player hang when joining server
« Reply #3 on: April 23, 2020, 09:20:52 am »
Reverting the container version to 0.25 and configuring the steam client to use branch stable-a25 worked to get my client up and running.  Good deal.

 ;D