Author Topic: (1.1.8) Unable to start single player game  (Read 2075 times)

asakul

  • Newbie
  • *
  • Posts: 1
    • View Profile
(1.1.8) Unable to start single player game
« on: April 03, 2015, 08:48:51 am »
Hi!
I'm trying to start a single player game, but when I'm pressing "Create new world" button, nothing happens.
At the same time, multiplayer seems to work.

Game version: 1.1.8 (Steam)
Game mode: Single
Bug Location: Main menu
Steps to Reproduce:
1. Start game
2. Select "Single player -> Create new world"
3. Nothing happens
Reproduction Rate: 100%
Logs: http://pastebin.com/ihWy6LNB
http://pastebin.com/mnkqSDAX


ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1128
    • View Profile
Re: (1.1.8) Unable to start single player game
« Reply #1 on: April 03, 2015, 09:06:52 am »
Hello!
The singleplayer part of the game is using local game server application built for Mono. Do you have Mono 3.10 installed?
The game should display a message about it, but as I can see in the logs it's failed due to exception. Will be fixed in the next build (in a 24 hours).
Regards!

optimizificationer

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: (1.1.8) Unable to start single player game
« Reply #2 on: April 04, 2015, 04:17:23 am »
I have the same problem and I also get an exception when VoidExpanse tries to start the server. I'm running arch linux x64. Multiplayer and connecting to a server I started manually (locally) with mono (3.12) works fine. This is with game version 1.1.8 and 1.2.0 over steam.

Latest log: http://pastebin.com/iz126Jev

EDIT: added log file
« Last Edit: April 04, 2015, 04:49:56 am by optimizificationer »

Corpser

  • Newbie
  • *
  • Posts: 1
    • View Profile
Re: (1.1.8) Unable to start single player game
« Reply #3 on: April 04, 2015, 11:49:10 am »
Good day all,

game won't find any single save games or start a new single player.

WIndows 8.0
Steam version of VE: 1.2.0

The VE starts up, however the program keeps saying: connecting to the game server when creating a new game or opening the saved game list.

Worked find all day yesterday.

Thanks y'all,
Corsper.

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1128
    • View Profile
Re: (1.1.8) Unable to start single player game
« Reply #4 on: April 04, 2015, 06:22:40 pm »
I have the same problem and I also get an exception when VoidExpanse tries to start the server. I'm running arch linux x64. Multiplayer and connecting to a server I started manually (locally) with mono (3.12) works fine. This is with game version 1.1.8 and 1.2.0 over steam.

Latest log: http://pastebin.com/iz126Jev

EDIT: added log file
Hello! Thanks for reporting! I'm sorry to say this. It seems that Unity is not fully compatible with Arch Linux. The game should get current process info when launch the local game server for singleplayer, but this method throws exception for this version of Linux (seems to be a broken implementation): "Can't find current process".
I will contact with Unity team but they tends to support only Ubuntu and Fedora, so I'm sure the issue is not going to be fixed soon. So you could play in multiplayer only.
Regards!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1128
    • View Profile
Re: (1.1.8) Unable to start single player game
« Reply #5 on: April 04, 2015, 06:24:22 pm »
Good day all,

game won't find any single save games or start a new single player.

WIndows 8.0
Steam version of VE: 1.2.0

The VE starts up, however the program keeps saying: connecting to the game server when creating a new game or opening the saved game list.

Worked find all day yesterday.

Thanks y'all,
Corsper.
Hello! Thanks for reporting.
Have you tried our suggestions from the wiki troubleshooting page? It seems the firewall blocked the game. But it's strange as you've played yesterday.
If the issue still persist, could you upload all game logs from /Documents/AtomicTorchStudio/VoidExpanse/Logs on Google Drive or Dropbox and provide the link please?
Regards!

optimizificationer

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: (1.1.8) Unable to start single player game
« Reply #6 on: April 04, 2015, 06:50:01 pm »
Hello! Thanks for reporting! I'm sorry to say this. It seems that Unity is not fully compatible with Arch Linux. The game should get current process info when launch the local game server for singleplayer, but this method throws exception for this version of Linux (seems to be a broken implementation): "Can't find current process".
I will contact with Unity team but they tends to support only Ubuntu and Fedora, so I'm sure the issue is not going to be fixed soon. So you could play in multiplayer only.
Regards!

I understand what the problem is, but since there is no detailed information about what went wrong, I can't find a solution. Is there no way to show a more verbose error message? Maybe some libs are missing to start the server or the process returned an error. Multiplayer is not really my thing in these kinds of games and starting everything by hand is only a temporary workaround. Hopefully you can provide some information.