Author Topic: [Resolved] Unable to launch server on MacOS  (Read 3138 times)

argast

  • Newbie
  • *
  • Posts: 2
    • View Profile
[Resolved] Unable to launch server on MacOS
« on: April 03, 2015, 09:51:16 am »
Hi,

I'm having problems starting singleplayer game. Game complains about not being able to launch server.

Here's the relevant log lines:

3.4.15 17:43:21.4820 [IMP] Starting server at: /Users/pawel/Library/Application Support/Steam/steamapps/common/VoidExpanse/voidexpanse.app/Contents/Server_Mono/VoidExpanse.ServerMono.exe
3.4.15 17:43:21.4842 [ERR] Unable to launch server: /Users/pawel/Library/Application Support/Steam/steamapps/common/VoidExpanse/voidexpanse.app/Contents/Server_Mono/VoidExpanse.ServerMono.exe
Exception System.ComponentModel.Win32Ex ception: ApplicationName='mono', CommandLine='"/Users/pawel/Library/Application Support/Steam/steamapps/common/VoidExpanse/voidexpanse.app/Contents/Server_Mono/VoidExpanse.ServerMono.exe" --singleplayer --parent_process_id 570 --port 65219 --steam 1', CurrentDirectory='/Users/pawel/Library/Application Support/Steam/steamapps/common/VoidExpanse/voidexpanse.app/Contents/Server_Mono'
   -------------------------stack-------------------------
  at System.Diagnostics.Process.St art_noshell (System.Diagnostics.ProcessSta rtInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
  at System.Diagnostics.Process.St art_common (System.Diagnostics.ProcessSta rtInfo startInfo, System.Diagnostics.Process process) [0x00000] in <filename unknown>:0
  at System.Diagnostics.Process.St art () [0x00000] in <filename unknown>:0
  at (wrapper remoting-invoke-with-check) System.Diagnostics.Process:Start ()
  at Assets.Scripts.LocalServerPro cessController.StartProcess (System.String serverExePath) [0x00000] in <filename unknown>:0
3.4.15 17:43:21.4872 [IMP] Dialog window shown: Unable to launch server: Please be sure you have Mono version 3.8.0 or higher installed and try again.
If you have any problems, check our wiki-page! [Support wiki] [Cancel]
3.4.15 17:43:21.5086 [IMP] Opening window: Dialog window "Unable to launch server"
3.4.15 17:43:21.5088 [IMP] ZIndex for window Dialog window "Unable to launch server" set to 1602
3.4.15 17:43:21.5116 [IMP] Window will be opened now: Dialog window "Unable to launch server"
3.4.15 17:43:23.0987 [IMP] OnApplicationFocus: game is not focused.
3.4.15 17:43:23.0991 [IMP] AudioSystem toggled mute sounds: yes
3.4.15 17:43:23.1010 [IMP] AudioSystem toggled mute music: yes
3.4.15 17:43:23.1016 [IMP] Pause music: menu_001.ogg



When I try to run server manually I get following output


mono "/Users/pawel/Library/Application Support/Steam/steamapps/common/VoidExpanse/voidexpanse.app/Contents/Server_Mono/VoidExpanse.ServerMono.exe" --singleplayer --parent_process_id 570 --port 59746 --steam 1  --verbose
Unknown heap type: #GUlD

Unknown heap type: #Blop

WSAIoctl: Need to translate 6 [Device not configured] into winsock error


Edit: I tried starting localhost server. It worked ok and I was able to join it. So it's only a problem with singleplayer.
« Last Edit: April 04, 2015, 03:51:37 am by ai_enabled »

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1612
    • View Profile
Re: Unable to launch server on MacOS
« Reply #1 on: April 03, 2015, 07:48:45 pm »
Hi!
It seems the game cannot launch the game server with shell - it seems the "mono" is an unknown application when it's executed by the game in this way.
So you need to add environment variable for Mono. Usually it's done automatically when installing the Mono.
Have you tried reinstalling the Mono?
Regards!

argast

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Unable to launch server on MacOS
« Reply #2 on: April 04, 2015, 02:17:44 am »
Hi,

Yes, it was installed via homebrew and that was a problem. When I reinstalled using installer from mono project website everything works fine.

Thanks for help!

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1612
    • View Profile
Re: Unable to launch server on MacOS
« Reply #3 on: April 04, 2015, 03:51:17 am »
Great to know!
Regards!