Author Topic: Ubuntu 16 New Server Setup issues  (Read 103 times)

Goretech

  • Newbie
  • *
  • Posts: 2
    • View Profile
Ubuntu 16 New Server Setup issues
« on: January 18, 2019, 02:10:27 pm »
So my friend and I just started playing this and first we used the Windows server.  Now that we know we like the game I wanted to set it up on my dedicated ubuntu server.

I installed mono through apt, per mono's website.   

So I am launching while in Server_Mono, the command mono VoidExpanse.ServerMono.exe --dedicated

This seems to go ok until I run "check"

Then I get two errors.

The first error only appears sometimes.  But the mod error is always.  Even though I've created that file.  I even tried 777 all permissions to see if it was an issue.  It does write logs though so I know it has access. 

Quote
[ERR] MasterServerClient: Unable to connect to Master Server atomictorch.com:4010 TCP
System.Net.Sockets.SocketExce ption: An established connection was aborted in your host machine.
   _____________________________ ________stack trace________________________ _____________

   at TcpSocketClient`1.ConnectInternal()
   at BaseNetworkClient`1.Connect()
   at MasterServerClient.ConnectSyn c()
   _____________________________ _____________________________ ___________________________
and
Quote
18.1.19 15:44:19.6220 [ERR] Critical exception
System.Exception: There is no core mod available! Unable to create new Mods Config at: /home/todd/Server_Mono/ModsConfig.xml
   _____________________________ ________stack trace________________________ _____________

   at ModsCatalog.RecoverOrRecreate ModsConfig(modsConfigAbsolutePath)
   at ModsCatalog.GetModsFromConfig(modTypeFilter, coreMod, writeToLog, isRecursiveCall)
   at FileSystemHelper.InitMods(xmlFilesProvider, fileSystemProvider)
   at Server.Init(args, isSingleplayer, config)
   at Program.Start(args)
   _____________________________ _____________________________ ___________________________

Full logs

Quote
todd@mediaserver:~/Server_Mono/Logs$ cat Server_VoidExpanse_2019-01-18_15-45.log
18.1.19 15:45:08.7338 [IMP] Log file opened. Time UTC offset is: -05:00:00
18.1.19 15:45:08.7379 [IMP] Console logging enabled
18.1.19 15:45:08.7814 [INF] VoidExpanse Game Server Runtime v2.1.1 (running on Unix)
AtomicTorch Studio (c) 2013-2015 | atomictorch.com
All rights reserved.
18.1.19 15:45:08.7816 [IMP] The server is now launched as the dedicated server. All server data will be loaded and processed in the current server folder.
18.1.19 15:45:08.7818 [IMP] Data folders locations:
   * Static data root path:  /home/todd
   * Dynamic data root path: /home/todd/Server_Mono/
   * Settings file location: /home/todd/Server_Mono/SettingsServer.xml
18.1.19 15:45:08.7819 [INF] Enter additional arguments line
("new [seed]" to create new world (the seed argument is optional), "load" to load the world, "check" to check mods)
18.1.19 15:45:13.4954 [IMP] Operations timed using the system's high-resolution performance counter.
  Timer is accurate within 100 nanoseconds
  Timer frequency in ticks per second = 10000000
18.1.19 15:45:13.5722 [IMP] The settings file loaded successfully from /home/todd/Server_Mono/SettingsServer.xml
18.1.19 15:45:13.6052 [INF] The configuration file saved successfully.
18.1.19 15:45:13.6053 [IMP] Current log severity: Important
18.1.19 15:45:13.6385 [IMP] Command binding completed successfully. Total bound commands count: 286.
18.1.19 15:45:13.7789 [IMP] Server icon size: 43230 bytes. Hash: ajuqn876pdtfk4n8xzsv1ivsyzqmu 4gbe6z0npztxiu=
18.1.19 15:45:13.7798 [IMP] Starting network server...
18.1.19 15:45:13.8840 [IMP] MasterServerClient: TCPClient: Socket-client connected to: X.X.X.X:4010 (TCP)
18.1.19 15:45:13.8951 [IMP] MasterServerClient: Connection to Master Server atomictorch.com:4010 established successfully
18.1.19 15:45:13.9362 [IMP] UDPServer: Socket-server listening on 0.0.0.0:5001 (UDP)
Connection timeout: 60s | Maximum network connections (with extra slots): 48
18.1.19 15:45:13.9398 [IMP] Server FPS set to 40
Ship params update fps is 7, so it called every 5 frame(s)
Network physics updates to clients fps is 20, so it called every 2 frame(s)
18.1.19 15:45:13.9465 [IMP] Mods catalog info (known mods locations):
Core folder: "/home/todd/Core"
Mods folder (primary): "/home/todd/Mods"
Mods folder (secondary): "/home/todd/Server_Mono/Mods"
18.1.19 15:45:13.9590 [IMP] Mods catalog initialzed. Available files:

18.1.19 15:45:13.9611 [IMP] Mods Config not located. Creating new one...
18.1.19 15:45:13.9689 [IMP] Disposing server instance
18.1.19 15:45:13.9704 [IMP] MasterServerClient: TCPClient: -- Closed connection
69.162.166.150:4010
18.1.19 15:45:13.9710 [IMP] MasterServerClient: TCPClient: -- Connection with 69.162.166.150:4010 closed --
18.1.19 15:45:13.9724 [IMP] MasterServerClient: Connection with Master Server closed successfully
18.1.19 15:45:13.9731 [IMP] UDPServer: Processing cycle for server connection stopped successfully by wait handle
18.1.19 15:45:13.9733 [IMP] UDPServer: Socket-server stop listening
18.1.19 15:45:13.9758 [ERR] Critical exception
System.Exception: There is no core mod available! Unable to create new Mods Config at: /home/todd/Server_Mono/ModsConfig.xml
   _____________________________ ________stack trace________________________ _____________

   at ModsCatalog.RecoverOrRecreate ModsConfig(modsConfigAbsolutePath)
   at ModsCatalog.GetModsFromConfig(modTypeFilter, coreMod, writeToLog, isRecursiveCall)
   at FileSystemHelper.InitMods(xmlFilesProvider, fileSystemProvider)
   at Server.Init(args, isSingleplayer, config)
   at Program.Start(args)
   _____________________________ _____________________________ ___________________________

18.1.19 15:45:13.9761 [IMP] Press any key to exit
18.1.19 15:45:19.1268 [IMP] Log file closed

ai_enabled

  • AtomicTorch Founder
  • Hero Member
  • *****
  • Posts: 1128
    • View Profile
Re: Ubuntu 16 New Server Setup issues
« Reply #1 on: January 21, 2019, 02:03:36 am »
Hello!

The server cannot run as it cannot locate the Core.cpk file. You need to copy the whole game folder - not only Server_Mono subfolder.

Regards!

Goretech

  • Newbie
  • *
  • Posts: 2
    • View Profile
Re: Ubuntu 16 New Server Setup issues
« Reply #2 on: January 23, 2019, 12:14:22 pm »
Works perfect, thanks!